import re
regex = re.compile(r"^(?=.{32}$)[a-zA-Z0-9]*[^\w\n][a-zA-Z0-9]*$", flags=re.MULTILINE)
test_str = ("123456789012345-7890123456789012\n"
"12345678901234567890123456789012\n"
"abcdefghijabcdefghijabcdefghijkl\n"
"abcdefghijabcdefghijabcdefghij1l\n"
"abcdefghijabcdefghijabcdefg\\ij1l")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")