import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{32}$)[a-zA-Z0-9]*[^\\w\\n][a-zA-Z0-9]*$";
final String string = "123456789012345-7890123456789012\n"
+ "12345678901234567890123456789012\n"
+ "abcdefghijabcdefghijabcdefghijkl\n"
+ "abcdefghijabcdefghijabcdefghij1l\n"
+ "abcdefghijabcdefghijabcdefg\\ij1l";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}