$re = '/^(?=.{32}$)[a-zA-Z0-9]*[^\w\n][a-zA-Z0-9]*$/m';
$str = '123456789012345-7890123456789012
12345678901234567890123456789012
abcdefghijabcdefghijabcdefghijkl
abcdefghijabcdefghijabcdefghij1l
abcdefghijabcdefghijabcdefg\\ij1l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);