import Foundation
let pattern = #"^(?=.{32}$)[a-zA-Z0-9]*[^\w\n][a-zA-Z0-9]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123456789012345-7890123456789012
12345678901234567890123456789012
abcdefghijabcdefghijabcdefghijkl
abcdefghijabcdefghijabcdefghij1l
abcdefghijabcdefghijabcdefg\ij1l
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)