using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<firstName>\p{Lu}(?:\.|\p{Ll}+)(?: \p{Lu}\.)?) (?<lastName>\p{L}\p{Ll}+(?:\p{Pd}\p{Lu})?\p{Ll}+)$";
string input = @"John Smith
John S. Smith
J. R. Smith";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}