re = /^(?<firstName>\p{Lu}(?:\.|\p{Ll}+)(?: \p{Lu}\.)?) (?<lastName>\p{L}\p{Ll}+(?:\p{Pd}\p{Lu})?\p{Ll}+)$/m
str = 'John Smith
John S. Smith
J. R. Smith'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end