$re = '/^(?<firstName>\p{Lu}(?:\.|\p{Ll}+)(?: \p{Lu}\.)?) (?<lastName>\p{L}\p{Ll}+(?:\p{Pd}\p{Lu})?\p{Ll}+)$/m';
$str = 'John Smith
John S. Smith
J. R. Smith';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);