using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{7,8}|[TD]\d{6,7}|TD\d{5,6})$";
string input = @"7 and 8 numbers: '1234567' and '12345678'
1234567
12345678
7 and 8 numbers that start with T: 'T234567' and 'T2345678'
T234567
T2345678
7 and 8 numbers that start with D: 'D234567' and 'D2345678'
D234567
D2345678
7 and 8 numbers that start with TD: 'TD34567' and 'TD345678'
TD34567
TD345678";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}