use strict;
my $str = '7 and 8 numbers: \'1234567\' and \'12345678\'
1234567
12345678
7 and 8 numbers that start with T: \'T234567\' and \'T2345678\'
T234567
T2345678
7 and 8 numbers that start with D: \'D234567\' and \'D2345678\'
D234567
D2345678
7 and 8 numbers that start with TD: \'TD34567\' and \'TD345678\'
TD34567
TD345678';
my $regex = qr/^(?:\d{7,8}|[TD]\d{6,7}|TD\d{5,6})$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}