# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d{7,8}|[TD]\d{6,7}|TD\d{5,6})$"
test_str = ("7 and 8 numbers: '1234567' and '12345678'\n"
"1234567\n"
"12345678\n"
"7 and 8 numbers that start with T: 'T234567' and 'T2345678'\n"
"T234567\n"
"T2345678\n"
"7 and 8 numbers that start with D: 'D234567' and 'D2345678'\n"
"D234567\n"
"D2345678\n"
"7 and 8 numbers that start with TD: 'TD34567' and 'TD345678'\n"
"TD34567\n"
"TD345678")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.