import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{7,8}|[TD]\\d{6,7}|TD\\d{5,6})$";
final String string = "7 and 8 numbers: '1234567' and '12345678'\n"
+ "1234567\n"
+ "12345678\n"
+ "7 and 8 numbers that start with T: 'T234567' and 'T2345678'\n"
+ "T234567\n"
+ "T2345678\n"
+ "7 and 8 numbers that start with D: 'D234567' and 'D2345678'\n"
+ "D234567\n"
+ "D2345678\n"
+ "7 and 8 numbers that start with TD: 'TD34567' and 'TD345678'\n"
+ "TD34567\n"
+ "TD345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}