const regex = new RegExp('^(?:\\d{7,8}|[TD]\\d{6,7}|TD\\d{5,6})$', 'gmi')
const str = `7 and 8 numbers: '1234567' and '12345678'
1234567
12345678
7 and 8 numbers that start with T: 'T234567' and 'T2345678'
T234567
T2345678
7 and 8 numbers that start with D: 'D234567' and 'D2345678'
D234567
D2345678
7 and 8 numbers that start with TD: 'TD34567' and 'TD345678'
TD34567
TD345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}