# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{1,11}).*$/$1/gm;t' <<< "12345678901:1020
12345678902:1030563"