re = /^(.{1,11}).*$/m
str = '12345678901:1020
12345678902:1030563'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result