const regex = /^(.{1,11}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{1,11}).*$', 'gm')
const str = `12345678901:1020
12345678902:1030563`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);