use strict;
my $str = '12345678901:1020
12345678902:1030563';
my $regex = qr/^(.{1,11}).*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";