# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^,]+),/\1/gm;t' <<< "S17,E108,736
S17,E109,737
"