$re = '/^([^,]+),/m';
$str = 'S17,E108,736
S17,E109,737
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;