import re
regex = re.compile(r"^([^,]+),", flags=re.MULTILINE)
test_str = ("S17,E108,736\n"
"S17,E109,737\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)