const regex = /^([^,]+),/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^,]+),', 'gm')
const str = `S17,E108,736
S17,E109,737
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);