# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\.)\bmyTable\b/myTable3/g;t' <<< "val changeMe= \"select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x\" "