import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\.)\\bmyTable\\b";
final String string = "val changeMe= \"select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x\" ";
final String subst = "myTable3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}