use strict;
my $str = 'val changeMe= "select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x" ';
my $regex = qr/(?<!\.)\bmyTable\b/p;
my $subst = 'myTable3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";