$re = '/(?<!\.)\bmyTable\b/';
$str = 'val changeMe= "select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x" ';
$subst = "myTable3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;