# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Maximum \(c\/s\)[ .]+//gm;t' <<< "91009-01-28-00 Maximum (c/s)................ 1543.5"