re = /Maximum \(c\/s\)[ .]+/m
str = '91009-01-28-00 Maximum (c/s)................ 1543.5'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result