use strict;
my $str = '91009-01-28-00 Maximum (c/s)................ 1543.5';
my $regex = qr/Maximum \(c/s\)[ .]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";