const regex = new RegExp('Maximum \\(c/s\\)[ .]+', 'gm')
const str = `91009-01-28-00 Maximum (c/s)................ 1543.5`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);