# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w*\d+\w*\s*//g;t' <<< "5asdas the food was thrill4 not2 that good 6son a5f asda sdasda324"