#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\w*\d+\w*\s*"
Local $sString = "5asdas the food was thrill4 not2 that good 6son a5f asda sdasda324"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)