$re = '`\w*\d+\w*\s*`';
$str = '5asdas the food was thrill4 not2 that good 6son a5f asda sdasda324';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;