import Foundation
let pattern = #"\w*\d+\w*\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"5asdas the food was thrill4 not2 that good 6son a5f asda sdasda324"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)