use strict;
my $str = '5asdas the food was thrill4 not2 that good 6son a5f asda sdasda324';
my $regex = qr`\w*\d+\w*\s*`p;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";