#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\b_*([a-z])[a-z]*(?:'s)?_*\b[^\n\w]*"
Local $sString = "Halley's Comet" & @CRLF & _
"First In, First Out" & @CRLF & _
"The Road _Not_ Taken" & @CRLF & _
"O'Brian's Dog"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)