import Foundation
let pattern = #"\b_*([a-z])[a-z]*(?:'s)?_*\b[^\n\w]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Halley's Comet
First In, First Out
The Road _Not_ Taken
O'Brian's Dog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)