$re = '`\b_*([a-z])[a-z]*(?:\'s)?_*\b[^\n\w]*`i';
$str = 'Halley\'s Comet
First In, First Out
The Road _Not_ Taken
O\'Brian\'s Dog';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;