use strict;
my $str = 'Halley\'s Comet
First In, First Out
The Road _Not_ Taken
O\'Brian\'s Dog';
my $regex = qr`\b_*([a-z])[a-z]*(?:'s)?_*\b[^\n\w]*`ip;
my $subst = '$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";