#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[2-9][0-9]{3}-W([0-5][0-3]|(?!00))"
Local $sString = "2021-W01" & @CRLF & _
"2021-W02" & @CRLF & _
"2021-W11" & @CRLF & _
"2021-W20" & @CRLF & _
"2021-W52" & @CRLF & _
"2021-W53" & @CRLF & _
"2021-W00" & @CRLF & _
"2021-W99" & @CRLF & _
"2021-W54" & @CRLF & _
"2021-W54" & @CRLF & _
"a021-a11" & @CRLF & _
"2021-W111" & @CRLF & _
"1000-W11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")