$re = '/^[2-9][0-9]{3}-W([0-5][0-3]|(?!00))/m';
$str = '2021-W01
2021-W02
2021-W11
2021-W20
2021-W52
2021-W53
2021-W00
2021-W99
2021-W54
2021-W54
a021-a11
2021-W111
1000-W11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);