using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[2-9][0-9]{3}-W([0-5][0-3]|(?!00))";
string input = @"2021-W01
2021-W02
2021-W11
2021-W20
2021-W52
2021-W53
2021-W00
2021-W99
2021-W54
2021-W54
a021-a11
2021-W111
1000-W11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}