use strict;
my $str = '2021-W01
2021-W02
2021-W11
2021-W20
2021-W52
2021-W53
2021-W00
2021-W99
2021-W54
2021-W54
a021-a11
2021-W111
1000-W11';
my $regex = qr/^[2-9][0-9]{3}-W([0-5][0-3]|(?!00))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}