# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[2-9][0-9]{3}-W([0-5][0-3]|(?!00))"
test_str = ("2021-W01\n"
"2021-W02\n"
"2021-W11\n"
"2021-W20\n"
"2021-W52\n"
"2021-W53\n"
"2021-W00\n"
"2021-W99\n"
"2021-W54\n"
"2021-W54\n"
"a021-a11\n"
"2021-W111\n"
"1000-W11")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.