using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Rate=(.*?)%";
string input = @"0CTL1141 - Ok : 74% used on a total of 95 GB for the ASP 1.|Used=71GB Total=95GB Rate=74% Evol=0%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}