use strict;
my $str = '0CTL1141 - Ok : 74% used on a total of 95 GB for the ASP 1.|Used=71GB Total=95GB Rate=74% Evol=0%';
my $regex = qr/Rate=(.*?)%/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}