re = /Rate=(.*?)%/m
str = '0CTL1141 - Ok : 74% used on a total of 95 GB for the ASP 1.|Used=71GB Total=95GB Rate=74% Evol=0%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end