package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Rate=(.*?)%`)
var str = `0CTL1141 - Ok : 74% used on a total of 95 GB for the ASP 1.|Used=71GB Total=95GB Rate=74% Evol=0%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}