// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Rate=(.*?)%").unwrap();
let string = "0CTL1141 - Ok : 74% used on a total of 95 GB for the ASP 1.|Used=71GB Total=95GB Rate=74% Evol=0%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}