# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!^)|\()([^)\s]*)\s+/$1$2/gm;t' <<< "foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )"