use strict;
my $str = 'foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )';
my $regex = qr/(\G(?!^)|\()([^)\s]*)\s+/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";