const regex = /(\G(?!^)|\()([^)\s]*)\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\G(?!^)|\\()([^)\\s]*)\\s+', 'gm')
const str = `foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);